surga Lab

開発したい!!

Xcodeがアップデートできなくなった時の解決策

Flutterへ入門しようと下記手順に従って設定していた時の話です。

flutter.dev

Xcodeがアップデートできませんでした。

環境

  • macOS High Sierra (詳細忘れた) -> macOS Mojave 10.14.5へ更新
  • Xcode 6.x

現象

私のXcodeはversion6で時が止まっていました。

iOS開発なんてほとんどやったことがなかったので。

Flutter開発にはXcodeの最新が必要なので
App Storeで更新かけようと思ったのですが、

アップデート一覧にXcodeが出てこない。

Xcodeを直接検索すると「開く」ボタンが表示されるが、押しても何も起きない。

LaunchpadのXcodeには車両通行止めのマーク...
押したらApp Storeが開くけど、相変わらず「開く」ボタンしかない。

解決策

検索しても解決策が見つからなかったのですが、Launchpadでoption押してXcodeを削除したら、App Storeで最新Xcodeをインストールできました。

今の所、Flutterのサンプルはうまく動いています。

単純でしたね。